ELMA RPA / ELMA RPA System Requirements

ELMA RPA System Requirements

These are the minimum system requirements for installing the ELMA RPA software and its correct work. They help to approximately assess compatibility of the company's equipment and ELMA RPA.

System requirements for ELMA RPA Designer

Operating system

MS Windows 8 or higher (х64)

Additional software

.NET Core SDK 5.0 Desktop Runtime 5.0

Recommended hardware requirements

Processor: 2 cores, the clock rate of 3 GHz or faster

Hard disk space: at least 5 GB on the disk

Memory: 2 GB

System requirements for ELMA RPA Bot

The technical requirements are specified for the bot when calculating the final characteristics of the ultimate work environment. Consider the technical requirements of the external applications the bot interacts with.

Operating system

MS Windows 8 or higher (х64)

Additional software

.NET Core SDK 5.0 Desktop Runtime 5.0

Recommended hardware requirements

Processor: 2 cores, the clock rate of 3 GHz or faster

Hard disk space: at least 5 GB on the disk

Memory: 512 MB

System requirements for ELMA RPA server on Windows

The operating system version depends on the possibility to install Docker on it.

Operating system

Windows 10 64-bit: Pro, Enterprise, or Education (Build 16299 or later), or Windows Server 2016 (Build 1607 or later)/Windows Server 2019

Additional software

Docker 19.03.1

Recommended hardware requirements

Processor: 2 cores, the clock rate of 3 GHz or faster (it is recommended to use the 8th Generation Intel Core processors or higer/AMD Zen or higher)

Hard disk space: at least 5 GB on the disk

Memory: 4 GB

System requirements for ELMA RPA server on Linux

Operating system

A 64-bit operating system

Additional software

Docker 19.03.1

Recommended hardware requirements

Processor: 2 cores, the clock rate of 3 GHz or faster (it is recommended to use Intel Xeon Dual Core)

Hard disk space: at least 10 GB on the disk

Memory: 4 GB

Found a typo? Highlight the text, press ctrl + enter and notify us